You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/fbset/fbset-2.1.ebuild

37 lines
750 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs flag-o-matic
DESCRIPTION="A utility to set the framebuffer videomode"
HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
IUSE="static"
BDEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
PATCHES=(
"${FILESDIR}/${P}-build.patch"
"${FILESDIR}/${P}-add-linux-types-h.patch"
)
src_compile() {
use static && append-ldflags -static
tc-export CC
emake
}
src_install() {
dobin fbset modeline2fb
doman *.[58]
dodoc etc/fb.modes.* INSTALL
}