You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/kcheck/kcheck-0.0.2-r1.ebuild

34 lines
777 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/wraeth/kcheck"
inherit git-r3
else
SRC_URI="https://github.com/wraeth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Record and check required kernel symbols are set"
HOMEPAGE="https://github.com/wraeth/kcheck"
LICENSE="MIT"
SLOT="0"
RDEPEND="
dev-python/configargparse[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]"
src_install() {
distutils-r1_src_install
mkdir "${D}"/etc || die
mv -v "${D}"/{usr/,}etc/kcheck.conf || die
rmdir -v "${D}"/usr/etc || die
}