You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/memtester/memtester-4.5.0.ebuild

28 lines
726 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="userspace utility for testing the memory subsystem for faults"
HOMEPAGE="http://pyropus.ca/software/memtester/"
SRC_URI="
http://pyropus.ca/software/memtester/${P}.tar.gz
http://pyropus.ca/software/memtester/old-versions/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
src_configure() {
echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
}
src_install() {
dosbin memtester
doman memtester.8
dodoc BUGS CHANGELOG README README.tests
}