You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/mlocate/mlocate-0.26-r2.ebuild

63 lines
1.5 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit user toolchain-funcs
DESCRIPTION="Merging locate is an utility to index and quickly search for files"
HOMEPAGE="https://pagure.io/mlocate"
SRC_URI="http://releases.pagure.org/mlocate/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="nls selinux"
RDEPEND="!sys-apps/slocate
!sys-apps/rlocate
selinux? ( sec-policy/selinux-slocate )"
DEPEND="app-arch/xz-utils
nls? ( sys-devel/gettext )
"
pkg_setup() {
enewgroup locate
}
src_configure() {
econf $(use_enable nls)
}
src_compile() {
emake groupname=locate AR="$(tc-getAR)"
}
src_install() {
emake groupname=locate DESTDIR="${D}" install
dodoc AUTHORS ChangeLog README NEWS
insinto /etc
doins "${FILESDIR}"/updatedb.conf
doins "${FILESDIR}"/mlocate-cron.conf
fperms 0644 /etc/{updatedb,mlocate-cron}.conf
insinto /etc/cron.daily
newins "${FILESDIR}"/mlocate.cron-r3 mlocate
fperms 0755 /etc/cron.daily/mlocate
fowners 0:locate /usr/bin/locate
fperms go-r,g+s /usr/bin/locate
keepdir /var/lib/mlocate
chown -R 0:locate "${ED}"/var/lib/mlocate
fperms 0750 /var/lib/mlocate
}
pkg_postinst() {
elog "The database for the locate command is generated daily by a cron job,"
elog "if you install for the first time you can run the updatedb command manually now."
elog
elog "Note that the /etc/updatedb.conf file is generic,"
elog "please customize it to your system requirements."
}