You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/pick/pick-4.0.0.ebuild

37 lines
697 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="A fuzzy search tool for the command-line"
HOMEPAGE="https://github.com/mptre/pick"
SRC_URI="https://github.com/mptre/pick/releases/download/v${PV}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="sys-libs/ncurses:0="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-4.0.0-tinfo.patch"
)
src_configure() {
# not autoconf
./configure || die
}
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
emake DESTDIR="${ED}" BINDIR=/usr/bin MANDIR=/usr/share/man install
dodoc CHANGELOG.md
}