You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/sed/sed-4.7.ebuild

50 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic
DESCRIPTION="Super-useful stream editor"
HOMEPAGE="http://sed.sourceforge.net/"
SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="acl nls selinux static"
RDEPEND="
!static? (
acl? ( virtual/acl )
nls? ( virtual/libintl )
selinux? ( sys-libs/libselinux )
)
"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
static? (
acl? ( virtual/acl[static-libs(+)] )
nls? ( virtual/libintl[static-libs(+)] )
selinux? ( sys-libs/libselinux[static-libs(+)] )
)
"
src_configure() {
local myconf=()
if use userland_GNU; then
myconf+=( --exec-prefix="${EPREFIX}" )
else
myconf+=( --program-prefix=g )
fi
export ac_cv_search_setfilecon=$(usex selinux -lselinux)
export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
use static && append-ldflags -static
myconf+=(
$(use_enable acl)
$(use_enable nls)
)
econf "${myconf[@]}"
}