You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/uam/uam-0.3.2-r1.ebuild

41 lines
1.2 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit udev
DESCRIPTION="Simple udev-based automounter for removable USB media"
HOMEPAGE="https://github.com/mgorny/uam/"
SRC_URI="https://github.com/mgorny/uam/releases/download/${P}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="
acct-group/plugdev
virtual/udev"
DEPEND="virtual/pkgconfig"
pkg_postinst() {
elog "To be able to access uam-mounted filesystems, you have to be"
elog "a member of the 'plugdev' group."
elog
elog "Note that uam doesn't provide any way to allow unprivileged user"
elog "to manually umount devices. The upstream suggested solution"
elog "is to use [sys-apps/pmount]. If you don't feel like installing"
elog "additional tools, remember to sync before removing your USB stick."
elog
elog "If you'd like uam to mount ejectable media like CDs/DVDs, you need"
elog "to enable in-kernel media polling, e.g.:"
elog " echo 5000 > /sys/module/block/parameters/events_dfl_poll_msecs"
elog "where 5000 would mean a poll will occur every 5 seconds."
elog
elog "If you'd like to receive libnotify-based notifications, you need"
elog "to install the [x11-misc/sw-notify-send] tool."
udev_reload
}