You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-auth/keystone/keystone-18.0.0.ebuild

157 lines
5.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_7 python3_8 )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="The Openstack authentication, authorization, and service catalog"
HOMEPAGE="https://launchpad.net/keystone"
if [[ ${PV} == *9999 ]];then
inherit git-r3
SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/victoria/keystone.conf.sample -> keystone.conf.sample-${PV}"
EGIT_REPO_URI="https://github.com/openstack/keystone.git"
EGIT_BRANCH="stable/victoria"
else
SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/keystone/victoria/keystone.conf.sample -> keystone.conf.sample-${PV}
https://tarballs.openstack.org/${PN}/${P}.tar.gz"
KEYWORDS="amd64 ~arm64 x86"
fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+sqlite ldap memcached mongo mysql postgres test"
RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
DEPEND="
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
>=dev-python/flask-1.0.2[${PYTHON_USEDEP}]
>=dev-python/flask-restful-0.3.5[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.7[${PYTHON_USEDEP}]
sqlite? (
>=dev-python/sqlalchemy-1.3.0[sqlite,${PYTHON_USEDEP}]
)
mysql? (
>=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
!~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
)
postgres? (
>=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
)
>=dev-python/sqlalchemy-migrate-0.13.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/passlib-1.7.0[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
>=dev-python/keystonemiddleware-7.0.0[${PYTHON_USEDEP}]
>=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
>=dev-python/scrypt-0.8.0[${PYTHON_USEDEP}]
>=dev-python/oslo-cache-1.26.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
>=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
>=dev-python/oslo-db-6.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
>=dev-python/oslo-log-3.44.0[${PYTHON_USEDEP}]
>=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
>=dev-python/oslo-policy-3.0.2[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
!~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
>=dev-python/oslo-upgradecheck-0.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
>=dev-python/pysaml2-5.0.0[${PYTHON_USEDEP}]
>=dev-python/pyjwt-1.6.1[${PYTHON_USEDEP}]
>=dev-python/dogpile-cache-1.0.2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
>=dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
!~dev-python/pycadf-2.0.0[${PYTHON_USEDEP}]
>=dev-python/msgpack-0.5.0[${PYTHON_USEDEP}]
>=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
memcached? (
>=dev-python/python-memcached-1.56[${PYTHON_USEDEP}]
)
mongo? (
>=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
!~dev-python/pymongo-3.1[${PYTHON_USEDEP}]
)
ldap? (
>=dev-python/python-ldap-3.1.0[${PYTHON_USEDEP}]
>=dev-python/ldappool-2.3.1[${PYTHON_USEDEP}]
)
|| (
www-servers/uwsgi[python,${PYTHON_USEDEP}]
www-apache/mod_wsgi[${PYTHON_USEDEP}]
www-servers/gunicorn[${PYTHON_USEDEP}]
)
acct-user/keystone
acct-group/keystone"
python_prepare_all() {
# it's in git, but not in the tarball.....
sed -i '/^hacking/d' test-requirements.txt || die
mkdir -p ${PN}/tests/tmp/ || die
sed -i 's|/usr/local|/usr|g' httpd/keystone-uwsgi-* || die
sed -i 's|python|python27|g' httpd/keystone-uwsgi-* || die
# allow useage of renamed msgpack
sed -i '/^msgpack/d' requirements.txt || die
distutils-r1_python_prepare_all
}
python_test() {
nosetests -I 'test_keystoneclient*' \
-e test_static_translated_string_is_Message \
-e test_get_token_id_error_handling \
-e test_provider_token_expiration_validation \
-e test_import --process-restartworker --process-timeout=60 || die "testsuite failed under python2.7"
}
python_install_all() {
distutils-r1_python_install_all
diropts -m 0750
keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
insopts -m0640 -okeystone -gkeystone
newins "${DISTDIR}/keystone.conf.sample-${PV}" keystone.conf.sample
doins etc/logging.conf.sample
doins etc/default_catalog.templates
# doins etc/policy.v3cloudsample.json
insinto /etc/keystone/httpd
doins httpd/*
fowners keystone:keystone /etc/keystone /etc/keystone/httpd /var/log/keystone
# stupid python doing stupid things
rm -r "${ED}"/usr/etc
}
pkg_postinst() {
elog "You might want to run:"
elog "emerge --config =${CATEGORY}/${PF}"
elog "if this is a new install."
elog "If you have not already configured your openssl installation"
elog "please do it by modifying /etc/ssl/openssl.cnf"
elog "BEFORE issuing the configuration command."
elog "Otherwise default values will be used."
}
pkg_config() {
if [ ! -d "${ROOT}"/etc/keystone/ssl ] ; then
einfo "Press ENTER to configure the keystone PKI, or Control-C to abort now..."
read
"${ROOT}"/usr/bin/keystone-manage pki_setup --keystone-user keystone --keystone-group keystone
else
einfo "keystone PKI certificates directory already present, skipping configuration"
fi
}