You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-cluster/projections/projections-6.2.1.ebuild

30 lines
641 B

# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit java-pkg-2
DESCRIPTION="Projections Performance Analysis Framework for Charm++ Applications"
HOMEPAGE="http://charm.cs.uiuc.edu/"
SRC_URI="http://charm.cs.illinois.edu/distrib/binaries/projections/projections_${PV}.tar.gz"
S="${WORKDIR}/${PN}_${PV}"
LICENSE="charm"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND="
>=virtual/jre-1.6
sys-cluster/charm[charmtracing]"
src_install() {
java-pkg_newjar ${PN}.jar
java-pkg_dolauncher ${PN} \
--main projections.analysis.ProjMain \
--jar ${PN}.jar
}