You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/automake-wrapper/automake-wrapper-11.ebuild

37 lines
898 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
DESCRIPTION="wrapper for automake to manage multiple automake versions"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
S=${WORKDIR}
src_unpack() {
cp "${FILESDIR}"/am-wrapper-${PV}.sh "${S}"/ || die
}
src_prepare() {
default
# usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
if use prefix ; then
sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' \
"${S}"/am-wrapper-${PV}.sh || die
fi
}
src_install() {
newbin "${S}"/am-wrapper-${PV}.sh automake
dosym automake /usr/bin/aclocal
keepdir /usr/share/aclocal
}