You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-devel/kgcc64/kgcc64-10.2.0.ebuild

43 lines
978 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
mips*) CTARGET=${CHOST/mips/mips64};;
powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
s390*) CTARGET=${CHOST/s390/s390x};;
sparc*) CTARGET=${CHOST/sparc/sparc64};;
i?86*) CTARGET=x86_64-${CHOST#*-};;
esac
export CTARGET
TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
PATCH_VER="1"
inherit toolchain
DESCRIPTION="64bit kernel compiler"
# Works on hppa and mips; all other archs, refer to bug #228115
KEYWORDS="~hppa"
# unlike every other target, hppa has not unified the 32/64 bit
# ports in binutils yet
DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
pkg_postinst() {
toolchain_pkg_postinst
cd "${ROOT}"/usr/bin
local x
for x in gcc cpp ; do
cat <<-EOF >${CTARGET%%-*}-linux-${x}
#!/bin/sh
exec ${CTARGET}-${x} "\$@"
EOF
chmod a+rx ${CTARGET%%-*}-linux-${x}
done
}