You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fabric/libmlx4/libmlx4-1.0.5.ebuild

32 lines
535 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
OFED_VER="3.12"
OFED_RC="1"
OFED_RC_VER="1"
OFED_SUFFIX="1.gdc6ef69"
inherit openib
DESCRIPTION="OpenIB userspace driver for Mellanox ConnectX HCA"
KEYWORDS="amd64 ~x86 ~amd64-linux"
IUSE=""
DEPEND="
sys-fabric/libibverbs:${SLOT}
"
RDEPEND="
!sys-fabric/openib-userspace"
block_other_ofed_versions
src_configure() {
econf --disable-static
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}