You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fabric/librdmacm/librdmacm-1.0.18-r1.ebuild

32 lines
709 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
OFED_VER="3.12"
OFED_RC="1"
OFED_RC_VER="1"
OFED_SUFFIX="1"
inherit eutils openib multilib-minimal
DESCRIPTION="OpenIB userspace RDMA CM library"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux"
IUSE="static-libs"
DEPEND="sys-fabric/libibverbs:${SLOT}[static-libs?,${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}
!sys-fabric/openib-userspace"
block_other_ofed_versions
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf $(use_enable static-libs static)
}
multilib_src_install_all() {
einstalldocs
use static-libs || find "${ED}/usr" -name '*.la' -delete
}