You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild

40 lines
713 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
HOMEPAGE="http://vu1tur.eu.org/tools"
SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
RDEPEND="app-arch/bzip2
sys-libs/zlib
dev-libs/openssl:0=
"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-openssl11.patch #674168
)
src_prepare() {
default
sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
}
src_compile() {
tc-export CC
emake CFLAGS="${CFLAGS}"
}
src_install() {
dobin dmg2img vfdecrypt
dodoc README
doman vfdecrypt.1
}