You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/duperemove/duperemove-0.11.2.ebuild

36 lines
701 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Btrfs and xfs deduplication utility"
HOMEPAGE="https://github.com/markfasheh/duperemove"
SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="
dev-db/sqlite:3
dev-libs/glib:2"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${P/_/.}
src_prepare() {
sed -i -e "/VER/s:0.12.dev:${PV}:" Makefile || die
default
}
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
}
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}