You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild

31 lines
613 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Simple MTP fuse filesystem driver"
HOMEPAGE="https://github.com/phatina/simple-mtpfs"
SRC_URI="https://github.com/phatina/simple-mtpfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
media-libs/libmtp
sys-fs/fuse:0"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/autoconf-archive
virtual/pkgconfig"
src_prepare() {
default
# The tarball doesn't contain ./configure, only configure.ac and
# autogen.sh.
eautoreconf
}