You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-kernel/zen-sources/zen-sources-5.11.15.ebuild

44 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
ETYPE="sources"
K_WANT_GENPATCHES="base extras"
K_GENPATCHES_VER="1"
K_SECURITY_UNSUPPORTED="1"
K_NOSETEXTRAVERSION="1"
ZEN_VER="v${PV}-zen1"
inherit kernel-2
detect_version
detect_arch
KEYWORDS="~amd64 ~x86"
HOMEPAGE="https://github.com/zen-kernel"
IUSE=""
DESCRIPTION="The Zen Kernel Live Sources"
ZEN_URI="https://github.com/zen-kernel/zen-kernel/releases/download/${ZEN_VER}/${ZEN_VER}.patch.xz"
SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${ZEN_URI}"
UNIPATCH_LIST="${DISTDIR}/${ZEN_VER}.patch.xz"
UNIPATCH_STRICTORDER="yes"
K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
${HOMEPAGE}, also go to #zen-sources on freenode"
pkg_setup() {
ewarn
ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
ewarn "If you need support, please contact the zen developers directly."
ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
ewarn "the ebuilds. Thank you."
ewarn
kernel-2_pkg_setup
}
pkg_postrm() {
kernel-2_pkg_postrm
}