You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-process/cronbase/cronbase-0.3.7-r6.ebuild

33 lines
663 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit user
DESCRIPTION="base for all cron ebuilds"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE=""
S=${WORKDIR}
pkg_setup() {
enewgroup cron 16
enewuser cron 16 -1 /var/spool/cron cron
}
src_install() {
newsbin "${FILESDIR}"/run-crons-${PV} run-crons
diropts -m0750
keepdir /etc/cron.{hourly,daily,weekly,monthly}
keepdir /var/spool/cron/lastrun
diropts -m0750 -o root -g cron
keepdir /var/spool/cron
}