You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/virtual/ruby-ssl/ruby-ssl-11.ebuild

27 lines
777 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
inherit ruby-ng
DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
RDEPEND="
ruby_targets_ruby25? ( dev-lang/ruby:2.5[ssl] )
ruby_targets_ruby26? ( dev-lang/ruby:2.6[ssl] )
ruby_targets_ruby27? ( dev-lang/ruby:2.7[ssl] )
ruby_targets_ruby30? ( dev-lang/ruby:3.0[ssl] )
"
pkg_setup() { :; }
src_unpack() { :; }
src_prepare() { eapply_user; }
src_compile() { :; }
src_install() { :; }
pkg_preinst() { :; }
pkg_postinst() { :; }