You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-misc/multisort/multisort-1.1-r2.ebuild

30 lines
601 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Merges httpd logfiles in the Common Log Format"
HOMEPAGE="https://www.xach.com/multisort/"
SRC_URI="https://www.xach.com/${PN}/${PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
src_prepare() {
default
# respect LDFLAGS wrt bug #337359
sed -i -e 's/$(CFLAGS)/& \$(LDFLAGS)/' Makefile || die 'sed on Makefile failed'
}
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
dosbin multisort
}