You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-base/xcb-proto/xcb-proto-1.14.1.ebuild

52 lines
1.2 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
XORG_TARBALL_SUFFIX="xz"
XORG_MODULE=proto/
XORG_MULTILIB=yes
inherit python-r1 xorg-3
DESCRIPTION="X C-language Bindings protocol headers"
HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=""
RDEPEND="
${PYTHON_DEPS}
"
BDEPEND="
${PYTHON_DEPS}
dev-libs/libxml2
"
ECONF_SOURCE="${S}"
multilib_src_configure() {
# Don't use Python to find sitedir here.
PYTHON=true default
}
src_compile() {
:
}
xcbgen_install() {
# Use eclass to find sitedir instead.
emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
python_optimize
}
multilib_src_install() {
# Restrict SUBDIRS to prevent xcbgen with empty sitedir.
emake install DESTDIR="${D}" SUBDIRS=src
multilib_is_native_abi && python_foreach_impl xcbgen_install
}