You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0....

34 lines
734 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
SRC_URI="https://github.com/mgorny/libtinynotify-systemwide/releases/download/${P}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
RDEPEND="sys-process/procps:0=
x11-libs/libtinynotify:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
src_configure() {
local myconf=(
$(use_enable doc gtk-doc)
$(use_enable static-libs static)
)
econf "${myconf[@]}"
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}