You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/libtinynotify/libtinynotify-9999.ebuild

43 lines
771 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
inherit autotools git-r3
DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
HOMEPAGE="https://github.com/mgorny/libtinynotify/"
SRC_URI=""
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
IUSE="debug doc static-libs"
RDEPEND="sys-apps/dbus:0="
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-1.18
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.18 )"
src_prepare() {
default
eautoreconf
}
src_configure() {
local myconf=(
$(use_enable debug)
$(use_enable doc gtk-doc)
$(use_enable static-libs static)
)
econf "${myconf[@]}"
}
src_install() {
default
find "${D}" -name '*.la' -delete
}