You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/apwal/apwal-0.4.5-r2.ebuild

35 lines
581 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="A simple application launcher and combined editor"
HOMEPAGE="http://apwal.free.fr/"
SRC_URI="http://apwal.free.fr/download/${P}.tar.gz"
S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
RDEPEND="
dev-libs/libxml2
dev-libs/glib:2
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
)
src_configure() {
tc-export CC PKG_CONFIG
}