You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/cbatticon/cbatticon-1.6.10.ebuild

52 lines
877 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit eutils toolchain-funcs
DESCRIPTION="A lightweight and fast battery icon that sits in your system tray"
HOMEPAGE="https://github.com/valr/cbatticon"
SRC_URI="https://github.com/valr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="libnotify"
RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:3
libnotify? ( x11-libs/libnotify )
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
src_prepare() {
default
strip-linguas -i .
}
src_compile() {
tc-export CC
emake \
$(usex libnotify WITH_NOTIFY=1 WITH_NOTIFY=0) \
V=1 \
VERSION="${PF}" \
WITH_GTK3=1
}
src_install() {
emake \
DESTDIR="${D}" \
DOCDIR="/usr/share/doc/${PF}" \
LANGUAGES="${LINGUAS}" \
V=1 VERSION="${PF}" \
install
dodoc Changelog
}