You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/chgres/chgres-0.1-r2.ebuild

37 lines
678 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="A very simple command line utility for changing X resolutions"
HOMEPAGE="http://hpwww.ec-lyon.fr/~vincent/"
SRC_URI="http://hpwww.ec-lyon.fr/~vincent/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXxf86dga
x11-libs/libXext
x11-libs/libXxf86vm"
DEPEND="${RDEPEND}
x11-base/xorg-proto
virtual/pkgconfig
"
PATCHES=( "${FILESDIR}"/${P}-{flags,includes}.patch )
src_prepare() {
default
tc-export CC PKG_CONFIG
}
src_install() {
dobin chgres
einstalldocs
}