You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/i3lock/i3lock-2.13.ebuild

42 lines
693 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Simple screen locker"
HOMEPAGE="https://i3wm.org/i3lock/"
SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
RDEPEND="
dev-libs/libev
sys-libs/pam
x11-libs/cairo[X,xcb(+)]
x11-libs/libxcb[xkb]
x11-libs/libxkbcommon[X]
x11-libs/xcb-util
x11-libs/xcb-util-xrm"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_prepare() {
default
sed -i -e 's:login:system-auth:g' pam/${PN} || die
}
src_configure() {
tc-export CC
default
}
src_install() {
default
doman ${PN}.1
}