You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/imwheel/imwheel-1.0.0_pre13_p201008...

39 lines
705 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="mouse tool for advanced features such as wheels and 3+ buttons"
HOMEPAGE="http://imwheel.sourceforge.net/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
RDEPEND="
x11-libs/libXtst
x11-libs/libX11
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=(
"${FILESDIR}"/${P}-autotools.patch # bug 726140
)
src_prepare() {
default
mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
# don't build gpm stuff
econf --disable-gpm --disable-gpm-doc
}