You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/qt5ct/qt5ct-1.2-r1.ebuild

54 lines
1023 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+dbus"
RDEPEND="
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5=
dev-qt/qtwidgets:5
dbus? (
dev-qt/qtdbus:5
dev-qt/qtgui:5[dbus]
)
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-qt/linguist-tools:5
dev-qt/qtpaths:5
"
PATCHES=(
"${FILESDIR}"/${P}-cmake.patch
)
src_install() {
cmake_src_install
newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
}
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
ewarn "qt5ct configuration won't be applied to the currently running sessions."
ewarn "Please relogin."
fi
if ! has_version 'dev-qt/qtsvg:5'; then
elog
elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
elog
fi
}