You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/sselp/sselp-9999.ebuild

31 lines
681 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit git-r3 toolchain-funcs
DESCRIPTION="Simple X selection printer"
HOMEPAGE="https://tools.suckless.org/x/sselp"
EGIT_REPO_URI="https://git.suckless.org/sselp"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
DEPEND="x11-libs/libX11"
RDEPEND="${DEPEND}"
src_prepare() {
default
sed -i \
-e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
-e "s|^LDFLAGS = -s|LDFLAGS +=|" \
-e "s|^CC = cc|CC = $(tc-getCC)|" \
config.mk || die "sed failed"
}
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
einstalldocs
}