You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/stalonetray/stalonetray-0.8.3.ebuild

34 lines
739 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
DESCRIPTION="System tray utility including support for KDE system tray icons"
HOMEPAGE="http://stalonetray.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug +graceful-exit kde"
RDEPEND="x11-libs/libX11
x11-libs/libICE
x11-libs/libSM
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
src_configure() {
econf $(use_enable debug) \
$(use_enable graceful-exit) \
$(use_enable kde native-kde)
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
dohtml stalonetray.html
}