You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/sxhkd/sxhkd-0.6.1.ebuild

28 lines
617 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs systemd
DESCRIPTION="Simple X hotkey daemon"
HOMEPAGE="https://github.com/baskerville/sxhkd/"
SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
RDEPEND="x11-libs/libxcb
x11-libs/xcb-util-keysyms"
DEPEND="${RDEPEND}
x11-libs/xcb-util"
src_compile() {
emake CC="$(tc-getCC)" PREFIX=/usr
}
src_install() {
emake PREFIX=/usr DESTDIR="${D}" install
systemd_dounit contrib/systemd/${PN}.service
}