You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xbindkeys/xbindkeys-1.8.6-r1.ebuild

30 lines
701 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
DESCRIPTION="Tool for launching commands on keystrokes"
SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="guile tk"
RDEPEND="x11-libs/libX11
guile? ( >=dev-scheme/guile-1.8.4[deprecated] )
tk? ( dev-lang/tk )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=(
"${FILESDIR}/${PN}-apply-mask-on-release-event-status.patch"
)
src_configure() {
econf \
$(use_enable tk) \
$(use_enable guile)
}