You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xdo/xdo-0.5.7.ebuild

27 lines
588 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Small X utility to perform elementary actions on windows"
HOMEPAGE="https://github.com/baskerville/xdo/"
SRC_URI="https://github.com/baskerville/xdo/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="x11-libs/libxcb
x11-libs/xcb-util
x11-libs/xcb-util-wm"
RDEPEND="${DEPEND}"
src_compile() {
emake CC="$(tc-getCC)" PREFIX=/usr
}
src_install() {
emake PREFIX=/usr DESTDIR="${D}" install
}