You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xdotool/xdotool-3.20160805.1.ebuild

58 lines
1.3 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs flag-o-matic multilib
DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
HOMEPAGE="https://www.semicomplete.com/projects/xdotool/"
SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
IUSE="examples"
RDEPEND="
x11-libs/libXtst
x11-libs/libX11
x11-libs/libXinerama
x11-libs/libxkbcommon
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto
"
# The test wants to manualy start Xvfb, wont use VirtualX and it tries
# to run a full gnome-session. For such a tiny application i consider
# it overkill to rewrite the test scripts to not use it's own X server
# and add a full blown gnome just to run the tests.
RESTRICT="test"
src_prepare() {
default
sed -i \
-e "s/installheader post-install$/installheader/" \
-e 's:\<pkg-config\>:$(PKG_CONFIG):' \
Makefile || die
}
src_compile() {
tc-export CC LD PKG_CONFIG
emake PREFIX="${EPREFIX}/usr"
}
src_install() {
emake PREFIX="${ED}usr" INSTALLMAN="${ED}usr/share/man" INSTALLLIB="${ED}usr/$(get_libdir)" install
dodoc CHANGELIST README
if use examples; then
dodoc -r examples
fi
}