You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1....

33 lines
691 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Plugin for Pidgin that reminds you of your buddies birthdays"
HOMEPAGE="https://launchpad.net/pidgin-birthday-reminder"
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="static-libs"
RDEPEND="net-im/pidgin[gtk]"
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
if ! use static-libs ; then
find "${D}" -type f -name '*.la' -delete || die "la removal failed"
fi
}