You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmamixer/wmamixer-1.0-r1.ebuild

34 lines
708 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="ALSA mixer dockapp, fork of wmsmixer"
HOMEPAGE="https://github.com/gryf/wmamixer"
SRC_URI="https://github.com/gryf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="media-libs/alsa-lib
x11-libs/libXpm
x11-libs/libXext
x11-libs/libX11"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
DOCS=( README.rst )
src_compile() {
$(tc-getCC) ${CFLAGS} -c -o wmamixer.o wmamixer.c
$(tc-getCC) ${LDFLAGS} -o wmamixer wmamixer.o -lm -lXpm -lXext -lX11 -lasound
}
src_install() {
dobin wmamixer
einstalldocs
}