You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmfortune/wmfortune-0.241-r1.ebuild

41 lines
803 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="a dockapp showing fortune-mod messages"
HOMEPAGE="https://www.dockapps.net/wmfortune"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="games-misc/fortune-mod
x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=( "${FILESDIR}"/${P}-stringh.patch )
src_prepare() {
# Honour Gentoo LDFLAGS. Closes bug #336446.
sed -i 's/-o $(DEST)/$(LDFLAGS) -o $(DEST)/' Makefile || die
default
}
src_compile() {
emake CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" \
XLIBDIR="/usr/$(get_libdir)"
}
src_install() {
dobin ${PN}
einstalldocs
}