You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmmaiload/wmmaiload-2.3.0-r2.ebuild

47 lines
1.0 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="dockapp that monitors one or more mailboxes"
HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86"
IUSE=""
RDEPEND="x11-libs/gtk+:2
x11-libs/libXpm"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-2.2.1-checkthread.patch
"${FILESDIR}"/${P}-fno-common.patch
"${FILESDIR}"/${P}-ssl.patch
)
src_configure() {
# The ./configure script is not autoconf based, therefore don't use econf:
./configure -p /usr || die
}
src_compile() {
emake \
CC="$(tc-getCC)" \
CPP="$(tc-getCPP)" \
CFLAGS="${CFLAGS}" \
DEBUG_LDFLAGS="" \
LDFLAGS="${LDFLAGS}" \
DEBUG_CFLAGS=""
}
src_install() {
dobin ${PN}/${PN} ${PN}-config/${PN}-config
doman doc/*.1
dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
}