You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-terms/alacritty/alacritty-9999.ebuild

127 lines
2.6 KiB

# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CRATES="
"
MY_PV="${PV//_rc/-rc}"
# https://bugs.gentoo.org/725962
PYTHON_COMPAT=( python3_{7,8,9} )
inherit bash-completion-r1 cargo desktop python-any-r1
DESCRIPTION="GPU-accelerated terminal emulator"
HOMEPAGE="https://github.com/alacritty/alacritty"
if [ ${PV} == "9999" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/alacritty/alacritty"
else
SRC_URI="https://github.com/alacritty/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
$(cargo_crate_uris ${CRATES})"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 BSD BSD-2 CC0-1.0 FTL ISC MIT MPL-2.0 Unlicense WTFPL-2 ZLIB"
SLOT="0"
IUSE="wayland +X"
REQUIRED_USE="|| ( wayland X )"
DEPEND="${PYTHON_DEPS}"
COMMON_DEPEND="
media-libs/fontconfig:=
media-libs/freetype:2
X? ( x11-libs/libxcb:=[xkb] )
"
RDEPEND="${COMMON_DEPEND}
media-libs/mesa[X?,wayland?]
sys-libs/zlib
sys-libs/ncurses:0
wayland? ( dev-libs/wayland )
X? (
x11-libs/libXcursor
x11-libs/libXi
x11-libs/libXrandr
)
"
BDEPEND="dev-util/cmake"
QA_FLAGS_IGNORED="usr/bin/alacritty"
S="${WORKDIR}/${PN}-${MY_PV}"
src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
cargo_live_src_unpack
else
cargo_src_unpack
fi
}
src_configure() {
local myfeatures=(
$(usex X x11 '')
$(usev wayland)
)
cargo_src_configure --no-default-features
}
src_compile() {
cd alacritty || die
cargo_src_compile
}
src_install() {
cargo_src_install --path alacritty
newman extra/alacritty.man alacritty.1
newbashcomp extra/completions/alacritty.bash alacritty
insinto /usr/share/fish/vendor_completions.d/
doins extra/completions/alacritty.fish
insinto /usr/share/zsh/site-functions
doins extra/completions/_alacritty
domenu extra/linux/Alacritty.desktop
newicon extra/logo/compat/alacritty-term.svg Alacritty.svg
newman extra/alacritty.man alacritty.1
insinto /usr/share/metainfo
doins extra/linux/io.alacritty.Alacritty.appdata.xml
insinto /usr/share/alacritty/scripts
doins -r scripts/*
local DOCS=(
alacritty.yml
CHANGELOG.md INSTALL.md README.md
docs/{ansicode.txt,escape_support.md,features.md}
)
einstalldocs
}
src_test() {
cd alacritty || die
cargo_src_test
}
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
einfo "Configuration files for ${CATEGORY}/${PN}"
einfo "in \$HOME may need to be updated after a version change"
einfo ""
einfo "An up-to-date sample configuration file can be found at"
einfo "${ROOT}/usr/share/doc/${PF}/alacritty.yml.bz2"
fi
}