You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r1.eb...

46 lines
1.4 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A high quality set of animated mouse cursors"
HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
RDEPEND="x11-libs/libXcursor"
src_install() {
insinto /usr/share/cursors/xorg-x11
doins -r cursors/*
}
pkg_postinst() {
einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
einfo "and add the following line (for example):"
einfo "Xcursor.theme: gentoo"
einfo ""
einfo "You can change the size by adding a line like:"
einfo "Xcursor.size: 48"
einfo ""
einfo "Also, to globally use this set of mouse cursors edit the file:"
einfo " /usr/local/share/cursors/xorg-x11/default/index.theme"
einfo "and change the line:"
einfo " Inherits=[current setting]"
einfo "to (for example)"
einfo " Inherits=gentoo"
einfo ""
einfo "Note this will be overruled by a user's ~/.Xdefaults file."
einfo ""
ewarn "If you experience flickering, try setting the following line in"
ewarn ""
ewarn "the Device section of your xorg.conf file:"
ewarn " Option \"HWCursor\" \"false\""
einfo ""
einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
}