You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-themes/gnome-themes-standard/gnome-themes-standard-3.28....

44 lines
1010 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
GNOME_ORG_MODULE="gnome-themes-extra"
inherit autotools gnome.org xdg
DESCRIPTION="Standard Themes for GNOME Applications"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-themes-extra"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
# their default background image
RDEPEND="
>=gnome-base/gsettings-desktop-schemas-3.4
"
BDEPEND="
>=dev-util/intltool-0.40
sys-devel/gettext
virtual/pkgconfig
"
PATCHES=(
# Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
"${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
--disable-static \
--disable-gtk2-engine \
--disable-gtk3-engine \
GTK_UPDATE_ICON_CACHE=$(type -P true)
}