You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-themes/gtk-theme-switch/gtk-theme-switch-2.1.0-r1.e...

38 lines
764 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Utility to switch and preview GTK+ theme"
HOMEPAGE="https://packages.qa.debian.org/g/gtk-theme-switch.html"
SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
default
sed -i \
-e 's:${GCC}:$(CC) $(LDFLAGS):' \
Makefile || die
}
src_compile() {
tc-export CC
emake CFLAGS="${CFLAGS} -Wall"
}
src_install() {
newbin ${PN}2 ${PN}
newman ${PN}2.1 ${PN}.1
dodoc ChangeLog readme todo
}