You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-themes/smplayer-skins/smplayer-skins-15.2.0-r1.eb...

33 lines
698 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit qmake-utils
DESCRIPTION="Skins for SMPlayer"
HOMEPAGE="https://www.smplayer.info/"
SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND="dev-qt/qtcore:5"
RDEPEND="media-video/smplayer"
src_prepare() {
default
sed -i -e 's/make/$(MAKE)/' Makefile || die
sed -i -e "s|rcc -binary|$(qt5_get_bindir)/&|" themes/Makefile || die
}
src_install() {
rm themes/Makefile || die
insinto /usr/share/smplayer
doins -r themes
dodoc Changelog README.txt
}