You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-base/xfce4-appfinder/xfce4-appfinder-4.16.1.ebuild

36 lines
864 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit xdg-utils
DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop"
HOMEPAGE="https://docs.xfce.org/xfce/xfce4-appfinder/start"
SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
RDEPEND=">=dev-libs/glib-2.50
>=x11-libs/gtk+-3.22:3
>=xfce-base/garcon-0.3:=
>=xfce-base/libxfce4util-4.15.2:=
>=xfce-base/libxfce4ui-4.14:=[gtk3(+)]
>=xfce-base/xfconf-4.14:=
!xfce-base/xfce-utils"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}