You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-base/xfdesktop/xfdesktop-4.16.0.ebuild

52 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit xdg-utils
DESCRIPTION="Desktop manager for the Xfce desktop environment"
HOMEPAGE="https://www.xfce.org/projects/"
SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="debug libnotify +thunar"
RDEPEND=">=x11-libs/cairo-1.12
>=dev-libs/glib-2.50
>=x11-libs/gtk+-3.22:3
>=x11-libs/libwnck-3.14:3
x11-libs/libX11
>=xfce-base/exo-0.11:=
>=xfce-base/garcon-0.6:=
>=xfce-base/libxfce4ui-4.13:=
>=xfce-base/libxfce4util-4.13:=
>=xfce-base/xfconf-4.12.1:=
libnotify? ( >=x11-libs/libnotify-0.7:= )
thunar? ( >=xfce-base/thunar-1.7:= )"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
src_configure() {
local myconf=(
$(use_enable thunar file-icons)
$(use_enable thunar thunarx)
$(use_enable libnotify notifications)
)
econf "${myconf[@]}"
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}