You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2....

52 lines
919 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake xdg-utils
DESCRIPTION="Alternate application launcher for Xfce"
HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE=""
RDEPEND="
virtual/libintl
x11-libs/gtk+:3
xfce-base/exo:=
xfce-base/garcon:=
xfce-base/libxfce4ui:=
xfce-base/libxfce4util:=
xfce-base/xfce4-panel:=
"
DEPEND="
${RDEPEND}
"
BDEPEND="
sys-devel/gettext
virtual/pkgconfig
"
src_configure() {
local mycmakeargs=(
-DENABLE_AS_NEEDED=OFF
-DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
-DENABLE_DEVELOPER_MODE=OFF
-DENABLE_LINK_TIME_OPTIMIZATION=OFF
)
cmake_src_configure
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}