You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.2.ebuild

44 lines
1.0 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="BSD-2 GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
DEPEND="gnome-base/librsvg:=
x11-libs/gtk+:3=
x11-libs/libwnck:3=
x11-libs/libX11:=
>=x11-libs/libxklavier-5.3:=
xfce-base/garcon:=
>=xfce-base/libxfce4ui-4.12:=
>=xfce-base/libxfce4util-4.12:=
>=xfce-base/xfce4-panel-4.12:=
>=xfce-base/xfconf-4.12.1:="
RDEPEND="${DEPEND}
x11-apps/setxkbmap
>=xfce-base/xfce4-settings-4.11"
BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
src_configure() {
local myconf=(
--libexecdir="${EPREFIX}"/usr/$(get_libdir)
)
econf "${myconf[@]}"
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}