You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/shellcheck/shellcheck-0.7.2.ebuild

36 lines
883 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
MY_PN="ShellCheck"
MY_P="${MY_PN}-${PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Shell script analysis tool"
HOMEPAGE="https://www.shellcheck.net/"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-haskell/aeson:=[profile?]
>=dev-haskell/diff-0.2.0:=[profile?]
>=dev-haskell/mtl-2.2.1:=[profile?]
>=dev-haskell/parsec-3.0:=[profile?]
>=dev-haskell/quickcheck-2.7.4:2=[template-haskell,profile?]
dev-haskell/regex-tdfa:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
"
PATCHES=("${FILESDIR}"/${P}-haddock.patch)