You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/vdr-pin/vdr-pin-0.1.14.ebuild

47 lines
1.0 KiB

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit vdr-plugin-2
VERSION="1379" # every bump, new version
DESCRIPTION="VDR plugin: enable/disable parentalrating in records"
HOMEPAGE="https://projects.vdr-developer.org/projects/plg-pin"
SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
KEYWORDS="~amd64 ~x86"
SLOT="0"
LICENSE="GPL-2"
IUSE=""
DEPEND=">=media-video/vdr-2.0.2-r1[pinplugin]"
RDEPEND="${DEPEND}"
src_prepare() {
vdr-plugin-2_src_prepare
sed -i "s:INCLUDES += -I\$(VDRINCDIR):INCLUDES += -I\$(VDRDIR)/include:" Makefile
if has_version ">=media-video/vdr-2.1.2"; then
sed -e "s#VideoDirectory#cVideoDirectory::Name\(\)#" \
-i pin.c
fi
}
src_install() {
vdr-plugin-2_src_install
dobin fskcheck
insinto /usr/share/vdr/plugins/${VDRPLUGIN}
doins "${S}"/scripts/fskprotect.sh
insinto /usr/share/vdr/record
newins "${S}"/scripts/cut.sh 20-preserve-pin-after-cut.sh
insinto /etc/vdr/reccmds
doins "${FILESDIR}"/reccmds.pin.conf
}